New(bie) member - need help

New Member Introductions
Post Reply
Ken
Posts: 5
Joined: Sat Jun 20, 2009 3:05 pm

New(bie) member - need help

Post by Ken » Sat Jun 20, 2009 3:34 pm

Hello everyone. It's great to find a forum like this where there's a wealth of experience and knowledge about these great guns. My dad passed away this year and so like a lot of you i'm sure, I inherited his collection. In the past few years he'd acquired a few guns I was unfamilar with but before he died I remember him talking about and showing me this one gun I had no idea about, it was a Model 8 he had picked up at a gun show. He always had this knowing look on his face when he handled it with a sly little smile which told me "yeah, now this is a really fine piece..." Well I didn't really appreciate it at the time but now that I have sat down and gotten to touch and feel and take apart this gun, I can appreciate what he felt. I got bitten by the bug and so after deciding the only thng to do with this rifle was to shoot it, I bought some ammo from Buffalo Arms in 30 Remington, joined the local NRA rifle range and got ready to find out what this thing was like to shoot.

I've inspected it carefully and find nothing wrong with it to my non-gunsmith eyes, smooth action, etc. Confident in its seemingly overbuilt nature I headed to the range and loaded my first round being careful not to slam the receiver closed but fully engaged. Leading up to that first trigger pull was a little nerve racking but eventually I pulled the trigger and <click>. Nothing. Visually checked everything, yup, everything looks right. OK, eject the round carefully and look at it. No dent on the primer. Dang, firing pin isn't working. Alright, lets put a different cartridge in it and try again. Same thing. Dang!

So I am guessing there are a few of you who know exactly what is going on here and I'm looking for some advise. Is the pin stuck, broken, spring? I am still learning this gun and am not a gun expert in general but I imagine it can only be one of a few things and I'm not sure how to appoach trouble-shooting it or repair. Any suggestions greatly appreciated.

I'll try post a few pcitures as soon as I can.

Looking forward to joining in here and getting this sucker to show me its stuff.

Ken
Posts: 5
Joined: Sat Jun 20, 2009 3:05 pm

Re: New(bie) member - need help

Post by Ken » Sat Jun 20, 2009 4:04 pm

Here's a few pictures of this well used/loved gun.

http://cid-7e5bda4f43b57789.skydrive.li ... qW0Da1Q%24

User avatar
81police
Posts: 2312
Joined: Thu Feb 05, 2009 12:12 pm
Location: TEXAS

Re: New(bie) member - need help

Post by 81police » Mon Jun 22, 2009 8:24 am

Glad to have you on the forum Ken. I've never personally experienced your problem w/ a model 8/81 but sounds like a broken firing pin. That would be the first thing I check.

If you need a copy of an original model 8 manual with instructions on how to remove the firing pin, go to the home page and click on "everything else 8/81's". There you will find a downloadable .pdf format manual. Hope this helps, let us know what you find out.

cam
Cam Woodall
Site Co-Administrator

Ken
Posts: 5
Joined: Sat Jun 20, 2009 3:05 pm

Re: New(bie) member - need help

Post by Ken » Mon Jun 22, 2009 8:58 am

Thanks for pointing out the pdfs. I'll study those and take a look at the firing pin, I suspect you are correct,

Ken
Posts: 5
Joined: Sat Jun 20, 2009 3:05 pm

Re: New(bie) member - need help

Post by Ken » Sun Jul 05, 2009 4:03 pm

Well, I'm learning as I go here. I've read most of Henwoods book now and I've taken the bolt out and the firing pin is definitely broken. I've stared at this thing for 45 minutes and it looks to me like the upper cam pim is missing since the diagram shows an upper and lower one. The bolt operates smoothly in the carrier but at this point I'm not very confident in it and not sure I can take this thing apart and get it back together again with a new firing pin and replace that upper pin.

Does anyone know of a gunsmith I could send this bolt assembly to to get it checked out and repaired?

User avatar
81police
Posts: 2312
Joined: Thu Feb 05, 2009 12:12 pm
Location: TEXAS

Re: New(bie) member - need help

Post by 81police » Mon Jul 06, 2009 12:52 pm

Ken, you might post in the "wanted" section for what you are looking for. There are a couple used firing pins for sale on gunbroker but you'll want to check and make sure which type you have.

http://gunbroker.com/Auction/ViewItem.a ... =133377934

http://gunbroker.com/Auction/ViewItem.a ... =133378590
Cam Woodall
Site Co-Administrator

Ken
Posts: 5
Joined: Sat Jun 20, 2009 3:05 pm

Re: New(bie) member - need help

Post by Ken » Mon Jul 06, 2009 1:15 pm

Thanks for the gunbroker.com reference, I'll see if I can match them up. I'll post over in the wanted section.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest